R2

                             s0                         s1

                            201                       301

                           dce                       dce









                         R1                              R3

                        102                             103

                        120대                          60대



로 구성







120대    c클래스*1/2  255.255.255.128  192.168.1.0~192.168.1.127  

60 대    c클래스*1/4  255.255.255.192   192.168.1.28~192.168.1.191



R1~R3 255.255.255.252  192.168.1.192~195





r1장비 셋팅하기



/*Frame-relay 스위치로 설정된 Router 를 통해 Router간 연결하는 방법*/

Router>
Router>en
Router#conf t
Router(config)#int e0 // 이더넷 IP설정 및 활성화
Router(config-if)#ip add 192.168.1.1 255.255.255.128
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int s0 // Serial0번 설정 및 활성화(IP는 넣어주지 않음)
Router(config-if)#encapsulation frame-relay
Router(config-if)#no sh
Router(config-if)#exit
Router(config)#int s0.1 point-to-point // Serial0번의 Sub-Interface생성
Router(config-subif)#ip add 192.168.1.193 255.255.255.252 // 각각의 Router의 Serial구간은 같은 네트워크여야함
Router(config-subif)#no sh
Router(config-subif)#bandwidth 64
Router(config-subif)#frame-relay interface-dlci 102 broadcast // 자신의 dlci값 설정
Router(config-fr-dlci)#router rip
Router(config-router)#version 2
Router(config-router)#network 192.168.1.0
Router(config-router)#network 192.168.1.192
Router(config-router)#end
Router#

/*구성 결과*/

Router#sh run
Building configuration...

Current configuration : 571 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.128
!
interface Serial0
no ip address
encapsulation frame-relay
!
interface Serial0.1 point-to-point
bandwidth 64
ip address 192.168.1.193 255.255.255.252
frame-relay interface-dlci 102
!
interface Serial1
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router#







r2장비 셋팅하기



/*Router를 Frame-relay 스위치로 설정하는 방법*/

Router>
Router>en
Router#conf t
Router(config)#frame-relay switching
Router(config)#int s0
Router(config-if)#encapsulation frame-relay
Router(config-if)#clock rate 72000
Router(config-if)#no sh
Router(config-if)#frame-relay interface-dlci 201 // serial0번의 dlci값
Router(config-fr-dlci)#frame-relay intf-type dce
Router(config-if)#frame-relay route 102 int s1 103 //serial0번의 102(dlci)번을 serial1번의 103번으로 연결
Router(config-if)#exit
Router(config)#int s1
Router(config-if)#encapsulation frame-relay
Router(config-if)#clock rate 72000
Router(config-if)#no sh
Router(config-if)#frame-relay interface-dlci 301 // serial1번의 dlci값
Router(config-fr-dlci)#frame-relay intf-type dce
Router(config-if)#frame-relay route 103 int s0 102 //serial1번의 103(dlci)번을 serial1번의 102번으로 연결
Router(config-if)#end
Router#

/*구성 결과*/

Router#sh run
Building configuration...

Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
ip subnet-zero
frame-relay switching
!
!
!
interface Ethernet0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial0
no ip address
no ip directed-broadcast
encapsulation frame-relay
clockrate 72000
frame-relay interface-dlci 201
frame-relay intf-type dce
frame-relay route 102 interface Serial1 103
!
interface Serial1
no ip address
no ip directed-broadcast
encapsulation frame-relay
clockrate 72000
frame-relay interface-dlci 301
frame-relay intf-type dce
frame-relay route 103 interface Serial0 102
!
ip classless
!
!
line con 0
transport input none
line aux 0
line vty 0 4
!
end

Router#







R3장비 셋팅하기..





router>enable
router#
router#configure terminal
router(config)#interface serial 0
router(config-if)#no ip address
router(config-if)#no shutdown
router(config-if)#encapsulation frame-relay
router(config-if)#interface serial0.1 point-to-point
router(config-subif)#ip address 192.168.1.194 255.255.255.252
router(config-subif)#no shutdown
router(config-subif)#bandwidth 64
router(config-subif)#frame-relay interface-dcli 103 broadcast
router(config-fr-dlci)#router rip
router(config-router)#version 2
router(config-router)#exit
router(config)#exit
router#
router#configure terminal
router(config)#interface e0
router(config-if)#ip address 192.168.1.129 255.255.255.192
router(config-if)#no shutdown
router(config-if)#ctrl^z
router#